Cloud Workspace - Minimum System Requirements

The Cloud Workspace client works on both Windows and Mac OSX as long as the minimum system requirements are met. Remote App is fully supported in both Windows and Mac OSX. Native full desktop is supported within the Windows client, whereas in Mac OSX we've got to manually configure the full desktop connection. Below are the system requirements to use the Cloud Workspace client to connect to your workspace environment.

*Sometimes some organizational Group Policies can cause issues with our single-sign on experience with the Cloud Workspace client.

Windows Remote Desktop Protocol Requirements:

To install the Cloud Workspace Client download for Windows, click here. We typically recommend running this installer as an administrative user to ensure everything is installed with elevated permissions. Once this finishes, you should be all set as long as your Remote Desktop Protocol is 8.1 or higher. See the steps below if you are unsure, or are on Windows 7.

You can find the version of Remote Desktop that your machine is on by going to run and typing in, mstsc. Hit enter. Click on the computer icon at the top left, and then click About.

If you do not see Remote Desktop Protocol 8.1 supported, you will need to upgrade. 

Image result for remote desktop 8.1 windows 7

Windows 7 SP1 Users: If your users are still on Windows 7 SP1, there is a required update that needs to be installed to upgrade the Remote Desktop Protocol version up to 8.1. This is the minimum version of RDP that is allowed to connect into your Cloud Workspace due to security requirements. Please click here and download/install the appropriate update.

Windows 10 Users: By default, Windows 10 has the required minimum RDP version (8.1). We recommend that you use the latest version which will be installed via Windows Updates. The version below is the most current:

 

Mac OSX Requirements:

For Mac OSX, we utilize the Microsoft Remote Desktop application that is available via the App Store. This requires Mac OSX 10.9 or later. We do support versions 8.0 and 10.0 of the application, right now version 8.0 has less bugs but Microsoft is continually working on making fixes to 10 and improving the experience.

You simply need to download the application from App Store, and then add Remote Resources using your WebFeed URL which will be provided to you via your Welcome e-mail, or you can contact our technical support for the address.

The URL looks like this: https://remoteapp.swizznet.com/8fhf/RDWeb/Feed/webfeed.aspx

 

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.